ホーム フォーラム 質問掲示板 テーマ変更をしていて画像が表示されない

  • このトピックには5件の返信、1人の参加者があり、最後に管理者3により4ヶ月、 2週前に更新されました。
6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • #34134
    くまがい
    ゲスト

    管理者様、お世話になっております。
    テーマのデザインを変更していて画像をいくつか使うため、
    imagesフォルダに画像をアップロードしたのですが、
    管理画面で確認すると壊れたデータになってしまっています。
    正常にアップロードするにはどうしたら良いでしょうか?

    #34136
    管理者3
    キーマスター

    くまがい 様

    EasyMailをご利用いただきありがとうございます。

    EasyMail管理画面>設定>テーマ>該当のテーマ>images フォルダーで
    画像を選択しても、表示されないことがこちらの環境でも確認されました。

    次回以降の改修の際に修正いたします。ご不便おかけして申し訳ありません。

    管理画面で画像が正しく表示されずとも、正常にアップロードされているかと思われます。
    一度テーマのデザインに組み込み表示されるかどうか試して頂けますでしょうか。

    #34137
    くまがい
    ゲスト

    ご返答いただきありがとうございます。
    テーマのデザインの方に組み込みしてみたのですが、
    表示させたい場所に画像ファイルはあるのですが
    「?」となっていてファイル表示されていない状態です。
    アップロードされていないことが原因でしょうか。。?

    #34139
    管理者3
    キーマスター

    くまがい様

    ファイルが表示されない原因は、アップロードに問題がある可能性もありますが
    パスやファイル権限の可能性もございます。一度以下3点ご確認いただけますでしょうか。

    ⑴ファイルパスの確認:
    HTMLまたはCSSで指定されている画像のパスと、実際に画像が保存されているパスが一致しているかを確認してください。
    パスに誤りがあると、画像が正しくアップロードされていても表示することができません。

    ⑵アップロード状況の確認:
    実際に画像ファイルがウェブサーバーにアップロードされているかを再度ご確認ください。
    又、該当の画像データを一度ダウロードし、正常に開くことができればファイルが壊れているということはないかと思います。

    ⑶上記2つの確認を行っても問題が解決しない場合は、
    ラウザの開発者ツールを使用してエラーメッセージを確認すると、さらに詳しい原因がわかるかもしれません。

    #34146
    くまがい
    ゲスト

    お世話になっております、ご回答いただきありがとうございます。
    (1)と(2)をどちらも確認しましたが、画像パスは一致しており、
    ファイルも壊れていないことが確認できました。
    (3)をしてみたところ、failed to load resourceというエラー表示になっており、
    画像ファイルが見つからない状態なようです。

    管理者様のサイトでは、画像表示は問題なくできておりますでしょうか?
    画像表示できている場合、もし可能でしたら画像表示部分の記述しているコードを
    参考に教えていただきたく思います。

    お忙しいところ申し訳ございませんが、よろしくお願いいたします。

    #34160
    管理者3
    キーマスター

    くまがい様

    ご回答が遅くなり申し訳ありません。

    オリジナルテーマの画像の参照について、こちらの
    フォーラムで回答しております。ご参考になれば幸いです。

    画像表示について

    またご不明点あればご連絡ください。

6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • このトピックに返信するにはログインが必要です。
あなたのサイトでEasyMailを
活用してください。

高機能で無料のメールフォーム「EasyMail」を
ぜひお試しください!